[vdr] [ANNOUNCE] vdr-xine-0.8.2 plugin

Reinhard Nissl rnissl at gmx.de
Mon Mar 17 00:21:59 CET 2008


Hi,

oleg roitburd schrieb:

>> Could you re-check with current xine-lib hg?
> 
> I made fresh checkout of ffmpeg trunk
> URL: svn://svn.mplayerhq.hu/ffmpeg/trunk
> Repository Root: svn://svn.mplayerhq.hu/ffmpeg
> Repository UUID: 9553f0bf-9b14-0410-a0b8-cfaf0461ba5b
> Revision: 12464
> Node Kind: directory
> Schedule: normal
> Last Changed Author: bcoudurier
> Last Changed Rev: 12464
> Last Changed Date: 2008-03-16 18:54:36 +0100 (Sun, 16 Mar 2008)
> Configured as follow:
>  ./configure --enable-shared --enable-gpl --enable-postproc
> --enable-liba52 --enable-libmp3lame --enable-libvorbis
> --enable-pthreads --enable-swscale
>
> Then I have cloned xine-lib ( 1.1)
> # hg identify
> c04027c00dc0+ tip
> Then I have patched with xine-lib.patch from xine-0.8.2, configured
>  ./autogen.sh --with-external-ffmpeg --disable-dxr3
> 
> And I became error
>  gcc -DHAVE_CONFIG_H -I. -I../.. -I../../include -I../../include
> -I../../src -I../../src/xine-engine -I../../src/xine-engine
> -I../../src/xine-utils -I../../src/input -I../../src/input -I../../lib
> -I../../lib -fvisibility=hidden -I/usr/local/include
> -I/usr/local/include -D_REENTRANT -D_FILE_OFFSET_BITS=64
> -DXINE_COMPILE -Wformat=2 -Wno-format-zero-length
> -Wmissing-format-attribute -Werror-implicit-function-declaration
> -Wstrict-aliasing=2 -mtune=pentiumpro -O3 -pipe -fomit-frame-pointer
> -falign-functions=4 -falign-loops=4 -falign-jumps=4
> -fexpensive-optimizations -fschedule-insns2 -ffast-math
> -finline-functions -Wall -Wpointer-arith -Wnested-externs -Wcast-align
> -Wchar-subscripts -Wmissing-declarations -Wmissing-prototypes -g -O2
> -DNDEBUG -MT xineplug_decode_ff_la-ffmpeg_decoder.lo -MD -MP -MF
> .deps/xineplug_decode_ff_la-ffmpeg_decoder.Tpo -c ffmpeg_decoder.c
> -fPIC -DPIC -o .libs/xineplug_decode_ff_la-ffmpeg_decoder.o
> In file included from ffmpeg_decoder.h:31,
>                  from ffmpeg_decoder.c:30:
> ./libavcodec/avcodec.h:34:20: error: avutil.h: No such file or directory
> In file included from ffmpeg_decoder.h:31,
>                  from ffmpeg_decoder.c:30:
> ./libavcodec/avcodec.h:716: error: expected specifier-qualifier-list
> before 'AVClass'
> ./libavcodec/avcodec.h:2098: error: expected ':', ',', ';', '}' or
> '__attribute__' before '*' token
> ./libavcodec/avcodec.h:2131: error: expected '=', ',', ';', 'asm' or
> '__attribute__' before 'attribute_deprecated'
> ./libavcodec/avcodec.h:2524: error: expected '=', ',', ';', 'asm' or
> '__attribute__' before 'int'
> make[3]: *** [xineplug_decode_ff_la-ffmpeg_decoder.lo] Error 1

Tried to reproduce this error by using the same versions as you
mentioned above (i. e. most recent ffmpeg-svn as well as most
recent xine-lib-1.1-hg), but it builds perfectly.

But I usually run configure in a separate build directory, i. e.

	./autogen.sh noconfig

in source directory and

	CFLAGS='-g3 -O3 -march=pentium4 -pipe' ../xine-lib-1.1/configure
--prefix=/soft/xine-lib-1.1-video --disable-debug
--with-external-ffmpeg --disable-dxr3

in build directory.

Are there any old files floating around?

	./libavcodec/avcodec.h

looks a bit strange to me.

Bye.
-- 
Dipl.-Inform. (FH) Reinhard Nissl
mailto:rnissl at gmx.de



More information about the vdr mailing list