[vdr] VDR and "multiproto" - which driver to use?

Lauri Tischler lwgt at iki.fi
Sat May 17 12:47:09 CEST 2008


Lauri Tischler wrote:
> Lauri Tischler wrote:
>> Halim Sahin wrote:
>>> Hi,
>>> On So, Apr 20, 2008 at 11:44:24 +0300, Lauri Tischler wrote:
>>>> Any particular requirement for kernel version,
>>>> i'm running 2.6.18-5-k7 (debian etch)at the moment ?
>>> HMM this kernel is too old!
>>> I think you need min 2.6.22 or better!
>>> I have tested it with 2.6.24 with gcc 4.2 and had no errors.
>> OK, upgrading to debian lenny, that has 2.6.24-5.
>> There will be interesting times ahead  ;)
> 
> Well, upgraded and compiled.

After updating Debian Lenny, multiproto_plus does not compile
anymore, after 'make clean; make' I get a lot of errors
---
vdr2:~/multiproto_plus# make
make -C /root/multiproto_plus/v4l
make[1]: Entering directory `/root/multiproto_plus/v4l'
creating symbolic links...
Kernel build directory is /lib/modules/2.6.24-1-686/build
make -C /lib/modules/2.6.24-1-686/build 
SUBDIRS=/root/multiproto_plus/v4l  modules
make[2]: Entering directory `/usr/src/linux-headers-2.6.24-1-686'
   CC [M]  /root/multiproto_plus/v4l/flexcop-pci.o
In file included from <command line>:1:
/root/multiproto_plus/v4l/config-compat.h:787:1: error: 
./linux/version.h: Too many levels of symbolic links
In file included from /root/multiproto_plus/v4l/flexcop-common.h:12,
                  from /root/multiproto_plus/v4l/flexcop-pci.c:10:
/root/multiproto_plus/v4l/compat.h:8:5: warning: "LINUX_VERSION_CODE" is 
not defined
/root/multiproto_plus/v4l/compat.h:8:26: warning: "KERNEL_VERSION" is 
not defined
/root/multiproto_plus/v4l/compat.h:8:40: error: missing binary operator 
before token "("
/root/multiproto_plus/v4l/compat.h:13:5: warning: "LINUX_VERSION_CODE" 
is not defined
/root/multiproto_plus/v4l/compat.h:13:27: warning: "KERNEL_VERSION" is 
not defined
---




More information about the vdr mailing list