[vdr] Building VDR 1.7.0 - skincurses error?

Jelle De Loecker skerit at kipdola.com
Thu May 22 09:16:49 CEST 2008


Udo Richter schreef:
> Jelle De Loecker wrote:
>   
>>     skincurses.c:793: error: ‘WINDOW’ was not declared in this scope
>>     skincurses.c:793: error: ‘w’ was not declared in this scope
>>     skincurses.c:793: error: ‘initscr’ was not declared in this scope
>>     
> The WINDOW data structure is provided by ncurses library. You may need a 
> different/newer version of libncurses-dev. (imho one of the 'wide 
> character' versions for unicode.)
>   
The solution was quite simple: The suse tutorials on the vdr wiki didn't 
say which dependencies you needed, like the libn5curses (or something 
like it)
Afterwards I had the same problem with some other plugins, but since 
they were in the repository I could do a  "apt-get build-dep 
vdr-plugins-burn" and most of the time that would have fixed it.


However, sometimes I needed to sift through the error messages and find 
the correct packages in synaptic.



More information about the vdr mailing list