[vdr] black screen with softdevice 0.5.0 and vdr 1.6

Leo Márquez vdr at leo.cat
Mon Oct 20 23:29:54 CEST 2008


Hi,

I am trying to set up a vdr with softdevice 0.5.0 (dfb) and vdr 1.6.
Vdr and softdevice compile fine but when I start vdr I get osd and audio and
no video.
The channels I want to see are dvb-t, no hd.
I did not see any error in logs. I remember have this problem few time ago
but any mailing list or google search helped me to remember what is the
problem and the solution.

Thank you!.

I put here the vdr output to help you know what is happening:

vdr:/usr/src/vdr16# ./vdr -c "/etc/vdr" -v "/videoteca/v0" -P"softdevice -vo
dfb:"
softdevice: Created setupStoreId 327681!
softdevice: Attatched to setupStoreId 327681 at 0xb78dd000.
[softdevice] processing args
[softdevice]   argv [0] = softdevice
[softdevice]   argv [1] = -vo
[setup-softdevice] alsa ac3Mode set to: 0
[setup-softdevice] alsa AC3 device set to: hw:0,1
[setup-softdevice] alsa device set to: default
[setup-softdevice] autodetectAspect 0
[setup-softdevice] A/V Offset set to (0)
[setup-softdevice] Cropping 0 lines from bottom
[setup-softdevice] Cropping 0 columns from left
[setup-softdevice] cropping mode set to 0 (none)
[setup-softdevice] cropping mode toggle key set to 0 (none)
[setup-softdevice] Cropping 0 columns from right
[setup-softdevice] Cropping 0 lines from top
[setup-softdevice] deinterlace method set to 1 lavc
[setup-softdevice] Expanding 0 columns at left and right
[setup-softdevice] Expanding 0 columns at top and bottom
[setup-softdevice] mainMenu: 1
[setup-softdevice] setting alpha blend mode to software
[softdevice] picture mirroring set to 0 (off)
[setup-softdevice] pixel format set to (I420)
[setup-softdevice] shouldSuspend to: 0
[setup-softdevice] syncTimerMode: sig
[softdevice] UseSetSourceRectangle to off
[softdevice] UseStretchBlitset to off
[setup-softdevice] vidBrightness: -1
[setup-softdevice] vidContrast: -1
[setup-softdevice] vidHue: -1
[setup-softdevice] vidSaturation: -1
[setup-softdevice] startup aspect set to (4:3 normal)
[softdevice] initializing Plugin
[softdevice] Initializing Video Out
[softdevice] ffmpeg build(3345152)
23:33:22.0883 I [5033] [dfb] init
(*) DirectFB/Config: Parsing config file '/etc/directfbrc'.
       ---------------------- DirectFB v0.9.25 ---------------------
             (c) 2000-2002  convergence integrated media GmbH
             (c) 2002-2004  convergence GmbH
        -----------------------------------------------------------
(*) DirectFB/Core: Single Application Core. (2006-12-04 07:00)
(*) Direct/Memcpy: Using MMXEXT optimized memcpy()
(*) Direct/Thread: Running 'VT Switcher' (CRITICAL, 5069)...
(*) Direct/Thread: Running 'PS/2 Input' (INPUT, 5070)...
 (!!!)  *** UNIMPLEMENTED [fusion_reactor_set_lock] ***
[../../../lib/fusion/reactor.c:853]
(*) DirectFB/Input: IMPS/2 Mouse 1.0 (Convergence GmbH)
(*) Direct/Thread: Running 'Keyboard Input' (INPUT, 5071)...
(*) DirectFB/Input: Keyboard 0.9 (convergence integrated media GmbH)
(*) Direct/Thread: Running 'Linux Input' (INPUT, 5072)...
(*) DirectFB/Input: AT Translated Set 2 keyboard (1) 0.1 (convergence
integrated media GmbH)
(*) Direct/Thread: Running 'Linux Input' (INPUT, 5073)...
(*) DirectFB/Input: cx88 IR (Hauppauge Nova-T DVB-T (2) 0.1 (convergence
integrated media GmbH)
(*) Direct/Thread: Running 'Linux Input' (INPUT, 5074)...
(*) DirectFB/Input: ImExPS/2 Generic Explorer Mouse (3) 0.1 (convergence
integrated media GmbH)
(*) DirectFB/Genefx: MMX detected and enabled
(*) DirectFB/Graphics: nVidia NV02 (0x002d) 0.6 (directfb.org)
(*) DirectFB/Core/WM: Default 0.2 (Convergence GmbH)
[dfb] RAM: 32505600 bytes
[dfb] Accellerated Functions: FillRectange DrawRectange DrawLine
FillTriangle Blit StretchBlit All
[dfb] Drawing Flags: Blend
[dfb] Surface Blitting Flags: BlendAlpha BlendColorAlpha Colorize
Deinterlace
23:33:23.0176 I [5033] [dfb] Supported video Modes are:
768x576 at 16 640x480 at 8 640x480 at 8 640x480 at 8 640x480 at 8 640x480 at 8 768x576 at 32
800x600 at 8 800x600 at 8 800x600 at 8 800x600 at 8 800x600 at 8 800x600 at 8 800x600 at 8
800x600 at 8 1024x768 at 8 1024x768 at 8 1024x768 at 8 1024x768 at 8 1024x768 at 8 1024x768 at 8
1024x768 at 8 1152x864 at 8 1152x864 at 8 1152x864 at 8 1152x864 at 8 1152x864 at 8 1152x864 at 8
1280x960 at 8 1280x960 at 16 1280x960 at 32 1024x1024 at 8 1280x1024 at 8 1280x1024 at 8
1280x1024 at 8 1280x1024 at 8 1280x1024 at 8
23:33:23.0178 I [5033] [dfb] Enumerating display Layers
23:33:23.0179 I [5033] [dfb] Configuring CooperativeLevel for OSD
Layer 0 FBDev Primary Layer  Type: graphics
  Caps: brightness contrast saturation surface
Layer 1 NVidia Overlay  Type: picture video
  Caps: brightness contrast deinterlacing dst_colorkey hue saturation
screen_location surface
23:33:23.0180 I [5033] [dfb] (osdLayer): flags, options, pixelformat:
0000000f, 00000000 00400c03
23:33:23.0181 I [5033] [dfb] (osdLayer): width, height:               768
576
23:33:23.0181 I [5033] [dfb] osdLayer without !! alpha channel
23:33:23.0188 D [5033] [dfb] surface capabilities for (scrSurface):
videoonly, double-buffered, flipping, PixelFormat = 0x00418c04
23:33:23.0189 I [5033] [dfb] width = 768, height = 576
23:33:23.0189 I [5033] [dfb] got fmt = 0x00418c04 bpp = 32
23:33:23.0192 I [5033] [dfb] Using this layer for OSD: (FBDev Primary Layer
- [768x576])
23:33:23.0192 D [5033] [dfb] surface capabilities for (osdSurface):
videoonly, double-buffered, flipping, PixelFormat = 0x00418c04
23:33:23.0192 I [5033] [dfb] Configuring CooperativeLevel for Overlay
23:33:23.0201 D [5033] [dfb] surface capabilities for (videoSurface):
videoonly, PixelFormat = 0x00200806
23:33:23.0201 I [5033] [dfb] Using this layer for OSD:        FBDev Primary
Layer
23:33:23.0202 I [5033] [dfb] Using this layer for Video out:  NVidia Overlay
23:33:23.0216 I [5033] [dfb] Display frame time is 13345 microseconds
23:33:23.0217 D [5033] [dfb] (re)configuring Videolayer to 720 x 576
(720x576)
23:33:23.0226 D [5033] [dfb] surface capabilities for (videoSurface):
systemonly, PixelFormat = 0x08100609
23:33:23.0226 D [5033] [dfb] (re)configured 0x08100609
[softdevice] Subplugin successfully opend
[softdevice] Video Out seems to be OK
[softdevice] Initializing Audio Out
[softdevice] Audio out seems to be OK
[softdevice] A/V devices initialized, now initializing MPEG2 Decoder
23:33:25.0843 D [5075] [dfb] (re)configuring Videolayer to 736 x 576
(736x576)
23:33:25.0853 D [5075] [dfb] surface capabilities for (videoSurface):
systemonly, PixelFormat = 0x08100609
23:33:25.0853 D [5075] [dfb] (re)configured 0x08100609
23:33:26.0616 D [5091] [VideoOut] reset: sync info: repF = 0, drpF = 0, totF
= 0
ALSA lib pcm.c:2143:(snd_pcm_open_noupdate) Unknown PCM CH2
allocating buffer format orig->format 0
23:33:26.0658 D [5093] [dfb] (re)configuring Videolayer to 720 x 576
(720x576)
23:33:26.0673 D [5093] [dfb] surface capabilities for (videoSurface):
systemonly, PixelFormat = 0x08100609
23:33:26.0673 D [5093] [dfb] (re)configured 0x08100609
23:33:27.0048 D [5093] [VideoOut] video now synced (9 - 0)
23:33:31.0884 D [5092] [softdevice-audio]: Xrun (at least 0,006 ms long)
23:33:32.0035 D [5092] [softdevice-audio]: Xrun (at least 0,006 ms long)
23:33:32.0337 D [5092] [softdevice-audio]: Xrun (at least 0,006 ms long)
23:33:44.0448 D [5092] [softdevice-audio]: Xrun (at least 0,008 ms long)
[setup-softdevice] restoring setup state
23:34:26.0211 D [5092] [softdevice-audio]: Xrun (at least 0,009 ms long)
23:34:58.0181 D [5092] [softdevice-audio]: Xrun (at least 0,008 ms long)
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.linuxtv.org/pipermail/vdr/attachments/20081020/4331f21b/attachment-0001.htm 


More information about the vdr mailing list