[vdr] VDR can no longer be compiled with the current driver from "http://linuxtv.org/hg/v4l-dvb".

Klaus Schmidinger Klaus.Schmidinger at tvdr.de
Sun Oct 25 14:58:27 CET 2009


On 22.10.2009 00:25, Carsten Koch wrote:
> On Sun, 2009-06-14 at 13:49 +0200, Klaus Schmidinger wrote:
> ...
>> If you use a full featured DVB card for replay you need the DVB driver
>> version from
>>
>>   http://linuxtv.org/hg/v4l-dvb
> 
> The driver had its API version changed on 2009-10-19 17:08:05:
> 
> --- v4l-dvb-af3d28c7ef19/linux/include/linux/dvb/version.h      2009-06-21 02:25:44.000000000 +0200
> +++ v4l-dvb-f6680fa8e7ec/linux/include/linux/dvb/version.h      2009-10-19 17:08:05.000000000 +0200
> @@ -24,6 +24,6 @@
>  #define _DVBVERSION_H_
> 
>  #define DVB_API_VERSION 5
> -#define DVB_API_VERSION_MINOR 0
> +#define DVB_API_VERSION_MINOR 1
> 
>  #endif /*_DVBVERSION_H_*/
> 
> 
> @Klaus, are you planning to adapt VDR and release a new version
> this weekend?

I've adapted the source like this:

--- dvbdevice.h 2009/06/06 11:16:47     2.8
+++ dvbdevice.h 2009/10/25 13:49:48
@@ -16,8 +16,8 @@
 #include "device.h"
 #include "dvbspu.h"

-#if DVB_API_VERSION != 5 || DVB_API_VERSION_MINOR != 0
-#error VDR requires Linux DVB driver API version 5.0!
+#if DVB_API_VERSION < 5
+#error VDR requires Linux DVB driver API version 5.0 or higher!
 #endif

 #define MAXDVBDEVICES  8



There won't be a new version this weekend, though.
I first need to debug the problem with not being able to
do FFWD/FREW in some HD recording.

Klaus



More information about the vdr mailing list