[vdr] Cam not decoding content (VDR 1.6 TT-1500 T CI PCI)

Simon Baxter linuxtv at nzbaxters.com
Thu Dec 16 19:31:37 CET 2010


> Dec 16 17:58:55 erin vdr: [2756] switching to channel 42
> Dec 16 17:58:55 erin vdr: [2884] transfer thread ended (pid=2756, 
> tid=2884)
> Dec 16 17:58:55 erin vdr: [2756] buffer stats: 40232 (1%) used
> Dec 16 17:58:55 erin vdr: [2888] transfer thread started (pid=2756,
> tid=2888)
> Dec 16 17:58:55 erin vdr: [2887] osdteletext-receiver thread ended
> (pid=2756, tid=2887)
> Dec 16 17:58:55 erin vdr: [2756] buffer stats: 0 (0%) used
> Dec 16 17:58:55 erin vdr: [2889] osdteletext-receiver thread started
> (pid=2756, tid=2889)
> Dec 16 17:58:56 erin vdr: [2888] [xine..put] Detected video size 704x576
> Dec 16 17:58:56 erin vdr: [2888] setting audio track to 1 (0)
> Dec 16 17:58:59 erin vdr: [2756] switching to channel 64
> Dec 16 17:58:59 erin vdr: [2888] transfer thread ended (pid=2756, 
> tid=2888)
> Dec 16 17:58:59 erin vdr: [2756] buffer stats: 75388 (3%) used
> Dec 16 17:58:59 erin vdr: [2889] osdteletext-receiver thread ended
> (pid=2756, tid=2889)
> Dec 16 17:58:59 erin vdr: [2890] transfer thread started (pid=2756,
> tid=2890)
> Dec 16 17:59:00 erin vdr: [2886] TS buffer on device 1 thread ended
> (pid=2756, tid=2886)
> Dec 16 17:59:00 erin vdr: [2885] buffer stats: 78960 (3%) used
> Dec 16 17:59:00 erin vdr: [2885] receiver on device 1 thread ended
> (pid=2756, tid=2885)
> Dec 16 17:59:00 erin vdr: [2891] receiver on device 1 thread started
> (pid=2756, tid=2891)
> Dec 16 17:59:00 erin vdr: [2756] buffer stats: 0 (0%) used
> Dec 16 17:59:00 erin vdr: [2756] creating directory
> /var/cache/osdteletext/T-8720-2213-32
> Dec 16 17:59:00 erin vdr: [2893] TS buffer on device 1 thread started
> (pid=2756, tid=2893)
> Dec 16 17:59:00 erin vdr: [2892] osdteletext-receiver thread started
> (pid=2756, tid=2892)
> Dec 16 17:59:01 erin vdr: [2756] retuning due to modification of channel 
> 64
> Dec 16 17:59:01 erin vdr: [2756] switching to channel 64
> Dec 16 17:59:01 erin vdr: [2890] transfer thread ended (pid=2756, 
> tid=2890)
> Dec 16 17:59:01 erin vdr: [2756] buffer stats: 39480 (1%) used
> Dec 16 17:59:01 erin vdr: [2894] transfer thread started (pid=2756,
> tid=2894)
> Dec 16 17:59:04 erin vdr: [2756] switching to channel 42
>
>
> any idea why the scrambled stream isn't being decoded?

Have you tried turning on debugging in ci.c?
// Set these to 'true' for debug output:
static bool DumpTPDUDataTransfer = false;
static bool DebugProtocol = false;
static bool DumpPolls = false;
static bool DumpDateTime = false;




More information about the vdr mailing list