[vdr] ERROR: driver buffer overflow on device 1

Reinhard Nissl rnissl at gmx.de
Wed Mar 17 20:36:36 CET 2010


Am 17.03.2010 07:23, schrieb Torgeir Veimo:
> On 14 March 2010 21:47, Reinhard Nissl <rnissl at gmx.de> wrote:
>> Hi,
>>
>> Am 14.03.2010 12:46, schrieb Goga777:
>>>>>>> I have experienced this problem several times today while on HD h264
>>>>>>> channels.  Like previously posted:
>>>>>>>
>>>>>>> Mar 12 15:02:23 vdr: [20675] buffer usage: 70% (tid=20674)
>>>>>>> Mar 12 15:02:24 vdr: [20675] buffer usage: 80% (tid=20674)
>>>>>>> Mar 12 15:02:24 vdr: [20675] buffer usage: 90% (tid=20674)
>>>>>>> Mar 12 15:02:25 vdr: [20675] buffer usage: 100% (tid=20674)
>>>>>>>
>>>>>>> VDR was unresponsive and had to be restarted to fix.
>>>>>>>
>>>>>>> Best regards,
>>>>>>> Derek
>>>>>>
>>>>>> Sorry, forgot to mention this is with VDR-1.7.13...
>>>>>
>>>>>
>>>>> I confirm - with vdr 1.7.13 still have the same issue
>>>>
>>>> I assume, you both use vdr-xine. It would be a good idea to
>>>> create a backtrace in that situation to rule out vdr-xine as
>>>> source of this issue.
>>>
>>> yes, I'm using the vdr-xine 093
>>> please advice how should I use backtrace
> 
> I see similar problems with xineliboutput, but I'm not sure it's
> exactly the same problem. I don't have to restart VDR, restarting the
> vdr-sxfe client is sufficient.

Hmm, looks like xine / vdr-sxfe would be to blame. There are some
cases where vdpau leaks images while decoding h264 video and when
no more images are left, xine / vdr-sxfe freezes and vdr runs
into an buffer overflow.

Does this happen too when not using vdpau?

Bye.
-- 
Dipl.-Inform. (FH) Reinhard Nissl
mailto:rnissl at gmx.de



More information about the vdr mailing list