[vdr] vdr <-> vdr-xine <-> xine-lib and vdpau and HD recordings

VDR User user.vdr at gmail.com
Thu Mar 31 17:48:55 CEST 2011


On Thu, Mar 31, 2011 at 8:27 AM, Joerg Riechardt <J.Riechardt at gmx.de> wrote:
> Hi,
> I have a problem with skipping during a replay of a HD recording.
> Running xine --verbose=2 I see after pressing the yellow button (skip +60
> sec) lots of
> video_out: throwing away image with pts xxxxxxx because it's too old (diff :
> yyyyy)
> messages.
> This is for a few seconds or forever, depending on system load, and causes
> 100% Cpu, and spoils recordings on my slow system. On faster systems you
> will hardly notice this.
> If I patch cDvbPlayer::SkipSeconds with
> -       readIndex = Index - 1; // Action() will first increment it!
> +       readIndex = Index; // Index - 1 causes problems in xine
> I no longer get those „throwing away image“ messages and the Cpu peak is
> only short and not that high.
>
> This happens also for starting a replay and for resuming replay after fast
> forward, but for those I have no vdr patch.
>
> I would very much appreciate if somebody with deeper knowledge of the
> interplay between vdr <-> vdr-xine <-> xine-lib would look into and comment
> on this.

Are you saying that when you press skip+/-, you get a delay before the
skip occurs?  If so, I experience this problem too.  Most of the time
when I press skip+/-, there's a 4-6 second pause before the skip
actually occurs.  Very aggravating to say the least.  The good news is
that Rnissl has this problem also so there's no need to try to
reproduce it -- he can already observe it locally.



More information about the vdr mailing list