[vdr] problems with playback and plugins with vdr-1.7.22

René linuxtv at hertell.com
Sat Jan 7 01:17:18 CET 2012


Hi all,

I finally managed to upgrade my vdr-1.6.x to vdr-1.7.22 and get the 
LiveBuffer patch compiled in Gentoo. There was however some problems i 
bumped into.

The first issue i have is when starting vdr. I get the following plugins 
to fail during startup:

ERROR: loading plugin libvdr-epgsearch.so.1.7.22: undefined symbol: 
_ZN6cTimerC1EbbP8cChannel
ERROR: loading plugin libvdr-skinenigmang.so.1.7.22: undefined symbol: 
_ZN6cTimerC1EbbP8cChannel
ERROR: loading plugin libvdr-text2skin.so.1.7.22: undefined symbol: 
_ZN6cTimerC1EbbP8cChannel
ERROR: loading plugin libvdr-burn.so.1.7.22: undefined symbol: 
_ZN8vdr_burn13chain_archiveC1ERNS_3jobE
ERROR: loading plugin libvdr-streamdev-server.so.1.7.22: undefined 
symbol: _ZN6cTimerC1EbbP8cChannel

I have compiled vdr, and after this i recompiled all plugins without any 
errors. The use-flags that are active are these:
cutterlimit ddepgentry hardlinkcutter lircsettings mainmenuhooks 
pinplugin timerinfo wareagleicon yaepg
The same use-flags worked fine with vdr 1.6.x

LiveBuffer for vdr-1.7.22 again failed with these use-flags: 
dvlvidprefer liemikuutio jumpplay setup ttxtsubs

Is there anything that i forgot to enable/disable in my setup?


Then i got an other problem. When watching a recording, and i 
fastforward of rewind the program, i get to a situation that the 
"timecounter" get's stuck to the frame i start from. The film moves, but 
when i hit play, i end up back to the frame from where i started to 
rewind/fastforwad. The only way to fix this is to jump with the 
yellow/green buttons. AFter this i can rewind/fastforwad normally. This 
again works for a while, but again if it fails to stop to the place i 
rewind to, i have to "reset" the rewind-issue with the yellow/green 
buttons...

Is this a known bug in vdr, or is it something that i have messed up in 
my setup?


Regards,

René



More information about the vdr mailing list