[vdr] Local frontend - using XBMC strm vs vdr-sxfe

Jonas Bardino jonas at bardinosen.dk
Fri Mar 9 16:50:44 CET 2012


On 2012-03-09 16:28, Dominic Evans wrote:
> On 9 March 2012 15:11, Jonas Bardino<jonas at bardinosen.dk>  wrote:
>> I launch vdr-sxfe with a command that overrides video_num_buffers,
>
> Thanks for the suggestions. I'll add the buffers cmdline to my
> vdr-sxfe startup. Interesting that you're using xvdr+tcp://localhost
> rather than the default unix pipe. Intentional?

That's a good question actually. I have experimented a *lot* with xine 
and xineliboutput to get sound through on the AAC/LATM encoded channels 
here in Denmark, so it may just be something that made a difference at 
some point along the way - I don't remember.
I'm pretty sure my playback glitches are from the combination of 
unstable-vdr and fairly new LATM support in ffmpeg/xine, but maybe I'll 
investigate if the pipe works better at some point.

>> The result is still not perfect with occasional glitches but it's not
>> bad and after fighting for months with just getting HD channels
>> running I'm quite happy.
>
> Yeah its great having HD channels playing and recording. It just makes
> me a little sad that XBMC playback of them is flawless, but with xine
> we seem to have to settle for "only occasionally glitches" ?

Here XBMC is absolutely unstable and always has been, while vdr-sxfe 
runs quite well. I haven't been able to get sound out of XBMC TV since 
the channel switch to LATM audio, either. It should be noted that I mean 
XBMC with TV over the various pvr plugins.

Cheers, Jonas



More information about the vdr mailing list