Hi,<br>I tried starting vdr without existing setup.conf and by default it seems that Sans Serif is used. But it seems that I don&#39;t have that either since Vdr still segfaults, now with following backtrace. By the way, is &quot;fc-list&quot; the correct way to check if certain font is available or not? According to fc-list I don&#39;t have Sans Serif.. 
<br><br>----------------<br>
Program received signal SIGSEGV, Segmentation fault.
<br>
[Switching to Thread -1211853120 (LWP 11533)]
<br>
0xb7ebe2f6 in FcCharSetCoverage () from /usr/lib/libfontconfig.so.1
<br>
(gdb) bt
<br>
#0&nbsp; 0xb7ebe2f6 in FcCharSetCoverage () from /usr/lib/libfontconfig.so.1
<br>
#1&nbsp; 0xb7ebe837 in FcNameParseCharSet () from /usr/lib/libfontconfig.so.1
<br>
#2&nbsp; 0xb7ec74c1 in FcNameParse () from /usr/lib/libfontconfig.so.1
<br>
#3&nbsp; 0xb7eb8660 in FcBlanksIsMember () from /usr/lib/libfontconfig.so.1
<br>
#4&nbsp; 0xb7eba52e in FcDirCacheReadDir () from /usr/lib/libfontconfig.so.1
<br>
#5&nbsp; 0xb7ec00c0 in FcDirScanConfig () from /usr/lib/libfontconfig.so.1
<br>
#6&nbsp; 0xb7ebaa47 in FcConfigBuildFonts () from /usr/lib/libfontconfig.so.1
<br>
#7&nbsp; 0xb7ec3413 in FcInitLoadConfigAndFonts () from /usr/lib/libfontconfig.so.1
<br>
#8&nbsp; 0xb7ec3638 in FcInit () from /usr/lib/libfontconfig.so.1
<br>
#9&nbsp; 0x080b37cf in cFont::GetFontFileName (FontName=0x815297c &quot;Sans Serif&quot;) at font.c:392
<br>
#10 0x080b4e59 in cFont::CreateFont (Name=0x8 &lt;Address&gt;, CharHeight=8, CharWidth=8) at font.c:337
<br>
#11 0x080b4ef5 in cFont::SetFont (Font=fontSml, Name=0x8 &lt;Address&gt;, CharHeight=8) at font.c:312
<br>
#12 0x080b4fcb in cFont::GetFont (Font=fontSml) at font.c:328
<br>
#13 0x080fc3ca in cSkinSTTNGDisplayMenu (this=0x8518268) at skinsttng.c:386
<br>
#14 0x080fcab2 in cSkinSTTNG::DisplayMenu (this=0x8515f60) at skinsttng.c:1146
<br>
#15 0x080b7348 in cInterface::LearnKeys (this=0x8515f28) at interface.c:165
<br>
#16 0x0810e8fb in main (argc=8, argv=0xbffad7e4) at vdr.c:662
<br><br>-Mika<br><br><div><span class="gmail_quote">2007/11/9, Lauri Tischler &lt;<a href="mailto:lwgt@iki.fi">lwgt@iki.fi</a>&gt;:</span><blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;">
Mika Orajärvi wrote:<br>&gt; Hi!<br>&gt;<br>&gt; I'm trying to update vdr 1.4.x to 1.5.11. But my vdr keeps segfaulting every<br>&gt; time when it's started. It takes about 2-3 s after starting the vdr to the<br>&gt; segfault. I've tried running it only with xine-plugin (
0.8.0) so far and<br>&gt; without any patches on top of vdr. And i'm running vdr on Ubuntu Dapper.<br>&gt;<br>&gt; GDB gives following backtrace, any ideas? It seems to be something related<br>&gt; to fonts,.. but beyond that I have no idea.
<br><br>VDR does crash if you dont have selected font available.<br>I can crash my 1.5.11 everytime when in OSD I select font<br>which I dont have, I tryed with &#39;small font&#39;.<br>Then I need to manually edit &#39;FontSml&#39; to existing font,
<br>Sans Serif.<br><br>_______________________________________________<br>vdr mailing list<br><a href="mailto:vdr@linuxtv.org">vdr@linuxtv.org</a><br><a href="http://www.linuxtv.org/cgi-bin/mailman/listinfo/vdr">http://www.linuxtv.org/cgi-bin/mailman/listinfo/vdr
</a><br></blockquote></div><br>