<html>
<head>
<style>
.hmmessage P
{
margin:0px;
padding:0px
}
body.hmmessage
{
FONT-SIZE: 10pt;
FONT-FAMILY:Tahoma
}
</style>
</head>
<body class='hmmessage'>
Hi there,<br><br>i'm not sure, if this problem is to specific. i'm using xineliboutput (cvs from 2008-07-02) and xine-lib (HG from 2008-06-17) - vdr is also pached with Reinhard Nissl addons to watch HD. i tested the "remote" frontend vdr-sxfe and also the "local" sxfe. if i start a rudimantary X session (via xinit) and start vdr-sxfe or with "local=sxfe" everything works realy fine. but a automated start via init scripts lead to a segmentation fault (using both frontends local sxfe or vdr-sxfe). <br><br>** that's the message:<br>--------------<br>Jul 25 16:00:48 localhost kernel: [&nbsp;&nbsp; 59.299437] Local decoder/d[7275]: segfault at 0 ip 7f994e00b277 sp 4768ffa0 error 4 in libxine.so.2.0.0[7f994dfcd000+53000]<br>--------------<br><br><br>** vdr's setup conf looks like this:<br>--------------<br>xineliboutput.Audio.Compression = 100<br>xineliboutput.Audio.Delay = 0<br>xineliboutput.Audio.Driver = alsa<br>xineliboutput.Audio.Headphone = 0<br>xineliboutput.Audio.Port = default<br>xineliboutput.Audio.SoftwareVolumeControl = 0<br>xineliboutput.Audio.Speakers = Stereo 2.0<br>xineliboutput.Audio.Surround = 0<br>xineliboutput.Audio.Upmix = 0<br>xineliboutput.Audio.Visualization = none<br>xineliboutput.Audio.Visualization.GoomOpts = width=720,height=576,fps=25<br>xineliboutput.Decoder.PesBuffers = 500<br>xineliboutput.DisplayAspect = automatic<br>xineliboutput.Frontend = sxfe<br>xineliboutput.Fullscreen = 1<br>xineliboutput.Media.BrowseFilesDir = /video<br>xineliboutput.Media.BrowseImagesDir = /video/vdr-1.7-ext<br>xineliboutput.Media.BrowseMusicDir = /video/vdr-1.7-ext<br>xineliboutput.Modeline =<br>xineliboutput.Post.denoise3d.chroma = 30<br>xineliboutput.Post.denoise3d.Enable = 0<br>xineliboutput.Post.denoise3d.luma = 40<br>xineliboutput.Post.denoise3d.time = 60<br>xineliboutput.Post.pp.Enable = 1<br>xineliboutput.Post.pp.Mode = de<br>xineliboutput.Post.pp.Quality = 0<br>xineliboutput.Post.unsharp.chroma_amount = 0<br>xineliboutput.Post.unsharp.chroma_matrix_height = 3<br>xineliboutput.Post.unsharp.chroma_matrix_width = 3<br>xineliboutput.Post.unsharp.Enable = 0<br>xineliboutput.Post.unsharp.luma_amount = 0<br>xineliboutput.Post.unsharp.luma_matrix_height = 5<br>xineliboutput.Post.unsharp.luma_matrix_width = 5<br>xineliboutput.Video.AspectRatio = 0<br>xineliboutput.Video.AutoCrop = 0<br>xineliboutput.Video.AutoCrop.AutoDetect = 1<br>xineliboutput.Video.AutoCrop.DetectSubs = 1<br>xineliboutput.Video.AutoCrop.FixedSize = 1<br>xineliboutput.Video.AutoCrop.SoftStart = 1<br>xineliboutput.Video.Brightness = -1<br>xineliboutput.Video.Contrast = -1<br>xineliboutput.Video.Deinterlace = tvtime<br>xineliboutput.Video.DeinterlaceOptions = method=Greedy2Frame,cheap_mode=1,pulldown=none,framerate_mode=full,judder_correction=1,use_progressive_frame_flag=1,chroma_filter=0,enabled=1<br>xineliboutput.Video.Driver = xv<br>xineliboutput.Video.FieldOrder = 0<br>xineliboutput.Video.HUE = -1<br>xineliboutput.Video.IBPTrickSpeed = 1<br>xineliboutput.Video.MaxTrickSpeed = 12<br>xineliboutput.Video.Overscan = 0<br>xineliboutput.Video.Port = :0.1<br>xineliboutput.Video.Saturation = -1<br>xineliboutput.Video.Scale = 0<br>xineliboutput.Video.SwScale = 1<br>xineliboutput.Video.SwScale.Aspect = 0<br>xineliboutput.Video.SwScale.Downscale = 0<br>xineliboutput.Video.SwScale.Height = 768<br>xineliboutput.Video.SwScale.Resize = 1<br>xineliboutput.Video.SwScale.Width = 1360<br>xineliboutput.VideoModeSwitching = 1<br>xineliboutput.X11.UseKeyboard = 1<br>xineliboutput.X11.WindowHeight = 768<br>xineliboutput.X11.WindowWidth = 1360<br>--------------<br><br>** the last loglines before the segfault are:<br>--------------<br>.<br>.<br>Jul 25 16:00:33 localhost vdr: [5781] [vdr-fe]&nbsp;&nbsp;&nbsp; Display size : 705 x 390 mm<br>Jul 25 16:00:33 localhost vdr: [5781] [vdr-fe]&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; 1360 x 768 pixels<br>Jul 25 16:00:33 localhost vdr: [5781] [vdr-fe]&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; 50dpi / 48dpi<br>Jul 25 16:00:33 localhost vdr: [5781] [vdr-fe]&nbsp;&nbsp;&nbsp; Display ratio: 1969,000000/1929,000000 = 1,020736<br>Jul 25 16:00:33 localhost vdr: [5781] [xine..put] cXinelibLocal::Action - fe-&gt;fe_display_open ok<br>Jul 25 16:00:33 localhost vdr: [5781] [xine..put] cXinelibLocal::Action - xine_init<br>Jul 25 16:00:33 localhost kernel: [&nbsp;&nbsp; 42.773530] Local decoder/d[5781]: segfault at 0 ip 7f6c08c2a277 sp 46ee7fa0 error 4 in libxine.so.2.0.0[7f6c08bec000+53<br>000]<br>--------------<br><br>** if i use the remote frontend, the error is nearly the same:<br>--------------<br><pre>Jul 21 08:39:20 localhost kernel: [  447.105564] vdr-sxfe[6041]: segfault at 0 ip 7f5e5e518277 sp 7fff676a5e50 error 4 in libxine.so.2.0.0[7f5e5e4da000+53000]<br>--------------<br><br><br></pre>The strange thing on this behaviour is that it works perfectly startet out of a console manually - but initiated via runlevel-scripts it segfaults. i also tested it with the latest cvs versions of xinelibouput and xine-lib -- same thing.<br><br>do you have any suggestions? <br><br>thanks a lot in advance!<br>ciax<br><br><br><br /><hr />Bis zu 500 Fotos im Monat für Freunde und Familie freigeben! Jetzt gratis auf Windows Live Spaces <a href='http://get.live.com/spaces/overview' target='_new'>Hier klicken!</a></body>
</html>