Talk:Hauppauge WinTV-HVR-2200

From LinuxTVWiki
Jump to navigation Jump to search


MythDora 10 Notes and experiences:

Sorry this page is kind of sloppy. It's my first Wiki, and I've only learned a couple of tags.

I had trouble getting Mythdora to work with my WinTV-HVR-2200, because I couldn't build the driver.

I kept getting Error 2 when running the make command.

I'm a relative Linux Newbie, and not a programmer, but I'm pretty good at deducing stuff and playing "detective" when it comes to computer stuff.

So, here's what I found out:

The latest Mythdora 10 release (see date above), is built on Fedora 10, which I use on another system, and like very much (especially once I've discovered yum!).

Google was my friend when researching the following problems, but I found the solutions in various, unrelated places relating to building drivers for other devices and versions of Linux.

The following steps do not work out of the box for Mythdora, but that can be fixed:

hg clone

This doesn't work because hg is a Mercurial command that is not installed with Mythdora. Solution:

# yum install mercurial

All of the make commands failed with Error 2, which is pretty generic, but it appears the main problem is the directory /lib/modules/2.6.<KernelVersion>/build was an invalid link.

That's because you don't have the kernel source files installed. Again, also easily fixed:

# yum install kernel-devel

I tried some other things because Google told me to, and reason tells me they are required. However, I did these before installing the kernel source, so I don't know if these are really required. It stands to reason that a C compiler would be needed to recompile the kernel. Linux lives on gcc, right?

# yum install gcc

I'm not sure what ncurses is, but you may need ncurses (already installed on my Mythdora) and ncurses-devel (not installed in my case).

# yum install ncurses-devel

Another couple of packages I installed, but these were probably a "wild goose chase" because the command after these did not work, and I installed the kernel source and solved my problem right after this:

# yum install rpmdevtools yum-utils

I would skip the above unless you still can't compile the driver.

I welcome someone well versed in Linux to clean up my notes above, clarify things I don't have a good understanding of, and merge this information into the main page for this tuner.

During my struggles above, my system updated MythTV to 0.22 (Luckily, the kernel had already updated before I built the driver.) So, mythfrontend was not running, and I had to go before I could resolve that issue.

2009-12-05: I had some other problems keeping mythfrontend from running, mainly because in the middle of my struggles, I took an upgrade to Myth 0.22. Since I'm just starting out, I might as well get the latest version to work, right? It turns out, I had a pesky "mythstreams" plug-in installed that was below 0.22, so I removed it:

# yum list mythstreams

(Maybe it's been updated to 0.22 since I wrote this, in which case, take it or leave it.)

If mythstreams is below 0.22, then:

# yum remove mythstreams

I've got TV!

The rest of my problems appear to not be related to this driver, so that's all for now.

I have an additional tuner in my machine, and whilst I can get the driver to load by specifying card=6 (board is a REV D3F2), it won't load correctly when the mythtv backend is running. I've found I need to shutdown the mythtv backend daemon, rmmod saa7164, then modprobe saa7164 card=6.

HVR2200 PCI revision 0070:8901 and recent 3.0+ kernels

The Hauppauge HVR-2200 with PCI revision 0070:8901 does not work correctly with later kernels. I had this card running successfully in Fedora 12 but when I tried to upgrade to a newer kernel, the card would not work and complained about a corrupt firmware file NXP7164-2010-03-10.1.fw (Once I had downloaded the firmware files from Steven Toth's site and moved them into /lib/firmware)

When the card works it was requesting an older firmware file v4l-saa7164-1.0.2-3.fw

In order to get the card to work, I modified the saa7164-fw.c file in the kernel source to use the older firmware files. There is a section at the top of the file that has the name of the firmware file to use and also the size of it. Change it from the NXP7164-2010-03-10.1.fw filename to v4l-saa7164-1.0.2-3.fw and then recompile the driver.

The older firmware does not enable analogue support, DVB-T only.

Steven Toth is aware of the issue and my work-around.

I tried 32 and 64 bit versions of Fedora 15 and 16 but I do not think it is a distribution specific issue, there are others with the 0070:8900 variant of the card that have the same issue.